Service Interruption: Netlify Image CDN Errors

Incident Report for U of G IT System

Resolved

This incident has been resolved.
Posted Jan 13, 2026 - 23:42 EST

Monitoring

The images are now restored and we are actively monitoring the status.
Posted Jan 13, 2026 - 13:27 EST

Investigating

We have identified there is a know image CDN loading issue on our webpages and the Netlify team is looking into it. We anticipate services to be back online soon.

We appreciate your patience and support as we work to resolve this issue.
Posted Jan 13, 2026 - 12:43 EST