Listserv is not accepting emailed messages

Incident Report for U of G IT System

Resolved

A network issue was preventing messages from being delivered to the Listserv and Maestro system. The problem was identified and resolved Messages should now be getting delivered normally, including any backlogged messages.

If you are continuing to encounter problems, please contact the helpdesk via email to ithelp@uoguelph.ca and we will investigate.
Posted Jul 07, 2026 - 14:47 EDT

Investigating

Since approx. 1:00 PM on Monday (6-Jun-2026) Listserv has not been receiving inbound messages. We are currently working to identify the root cause. Please note that the messages are queued for delivery when the issue is resolved.

In the interim, if a message urgently needs to be sent out, messages created using the Listserv web interface will be delivered.

We will update this incident as more information is available.
Posted Jul 07, 2026 - 10:59 EDT