Microsoft 365 email may be intermittently delayed
Incident Report for University of Guelph IT System
Resolved
Microsoft confirms they have rolled back the recent change that inadvertently caused this problem. Email ought to be flowing normally once again. As always, we apologize for any inconvenience, and thank you for your patience.
Posted Apr 17, 2024 - 16:15 EDT
Identified
Microsoft has acknowledged a problem with email messages. Inbound and outbound email messages may be intermittently delayed when sending through Exchange Online. Some users have reported that they can't send or receive messages at all.

Microsoft is actively working on this issue and have promised an update by 3:30 PM at the latest.

Thank you for your patience and support.
Posted Apr 17, 2024 - 13:54 EDT