M365 Outlook: Users may be unable to access their mailbox using any connection methods

Incident Report for U of G IT System

Resolved

Microsoft has applied the configuration and considers the mailbox access issue resolved.

If you are continuing to experience issues accessing mail via Outlook then please contact CCS Help, ithelp@uoguelph.ca.
Posted Jul 10, 2025 - 16:14 EDT

Update

Update [12:32pm]: Microsoft reports that they are applying 'a configuration change' to address issue with accessing Outlook mailboxes. They expect the change to take effect within the next 2 hours.

Microsoft will provide another update at 2:30pm today.
Posted Jul 10, 2025 - 12:40 EDT

Monitoring

CCS is monitoring an issue Microsoft has reported that is prevented some users from accessing their uoguelph.ca mailboxes.

According to Microsoft, "Users attempting to access their Exchange Online mailbox using any connection methods may be impacted."

The CCS Help Center is aware of the issue and CCS Email and Collaboration team will continue to monitor Microsoft's progress as they continue to address the issue. Updates when available will be shared throughout the day.
Posted Jul 10, 2025 - 10:53 EDT