Service Interruption: ListServ and Maestro
Incident Report for CCS System
Resolved
ListServ and Maestro functionality have been restored, and any messages sent during the downtime should be queue’d for delivery now. If you experience any issues with ListServ, please contact the Help Center at 58888help@uoguelph.ca or ext. 58888. Thank you!
Posted 4 months ago. May 15, 2018 - 09:59 EDT
Investigating
We are experiencing a critical issue with ListServ and Maestro as of 4:30pm on Monday, May 14th. We are currently investigating the root cause of this issue.

Should you require assistance during this time, please contact the CCS Help Centre at 519-824-4120 x58888 or 58888help@uoguelph.ca. If after hours, please leave a message and your call will be returned on the next business day.

We will provide updates on this page every 2 hours until resolution of the issue. We appreciate your patience and support as we work to resolve this issue.
Posted 4 months ago. May 15, 2018 - 09:17 EDT