U of G Website Service Interruption: Various web pages slow or not loading

Incident Report for U of G IT System

Update

Websites have remained mostly stable with the workaround in place. We have been working on a more permanent fix behind the scenes, and are implementing it soon. We will continue to monitor overnight and provide our next update at the beginning of the business day tomorrow, unless things worsen.
Posted Jun 22, 2026 - 16:25 EDT

Monitoring

We have identified the cause of the issue and have implemented a temporary workaround to bring web pages back online.

We will continue to monitor the situation.
Posted Jun 22, 2026 - 14:21 EDT

Investigating

We are experiencing issues with U of G web pages as of approximately 12:50 PM. We are currently investigating the cause of this issue.

Numerous web pages are impacted, including, but not limited to:

- uoguelph.ca/registrar
- WebAdvisor
- uoguelph.ca/research
- uoguelph.ca/ovc

We will provide updates on this page until resolution of the issue.

We appreciate your patience and support as we work to resolve this issue.
Posted Jun 22, 2026 - 13:06 EDT