Our ISP has confirmed that all fibre cable repairs are complete without any further service impacts. This incident has been resolved.
Posted Mar 26, 2026 - 15:05 EDT
Update
Network services have been restored to Ridgetown, Elora Research, Research Park, Library Annex, and Gordon Hall.
No further outage is expected, however we are continuing to monitor service presence and stability while the ISP proceeds with repairing the remaining fibre cables.
Posted Mar 26, 2026 - 08:21 EDT
Update
The ISP has advised that the splicing work is still ongoing as of 6.30 am.
CCS continues to monitor the affected remote site connections.
The next update is expected by 8 am.
We apologize for any inconvenience and appreciate everybody's patience and support.
Posted Mar 26, 2026 - 06:45 EDT
Monitoring
According to Rogers, the Fibre team continues to prepare the cables for splicing. Once the preparation is complete, the crew will begin splicing the larger of the cables. some services will begin to recover as splicing progresses but they expect full service recovery will not be before 4 or 5 AM.
CCS will continue to monitor the situation and provide an update early tomorrow morning.
We apologize for any inconvenience.
Posted Mar 25, 2026 - 20:43 EDT
Update
ISP repair crews have confirmed that a section of the fibre infrastructure requires replacement. Work is currently underway. They advise that this phase of the repair is expected to take approximately four hours.
Additional repair crews are on site preparing the fibre for restoration, with multiple teams working in parallel to expedite recovery efforts.
The next update is expected by 8 pm.
Everybody's continued patience and support is greatly appreciated.
Posted Mar 25, 2026 - 18:19 EDT
Update
ISP technicians have confirmed fibre damage resulting from a vehicle accident. Repair Work is actively underway to restore service as quickly and safely as possible.
The next update is expected by 6 pm.
We appreciate everybody's understanding and patience.
Posted Mar 25, 2026 - 16:54 EDT
Update
The Internet Service Provider (ISP) has acknowledged that this issue is caused by a fibre cut and affects the broader Guelph area. Technicians have been dispatched to repair the fibre connection.
We expect to receive another update by 5 pm.
Posted Mar 25, 2026 - 15:00 EDT
Identified
A service outage has occurred with one of the University ISPs. Guelph campus services were only briefly affected and have recovered, but several remote sites, including Ridgetown, Elora Research, Research Park, and Gordon Hall are currently impacted.
We currently are assessing impact and following up with the service provider for more information. Additional updates to follow.