Network Authentication Servers Maintenance

Scheduled for May 2, 06:00 - 12:00 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted May 01, 2026 - 09:16 EDT

Scheduled

The network authentication servers for VPN, wired ports (residence and public ports) and wireless guest services will be undergoing maintenance.

Several brief interruptions in service are expected.
Posted May 01, 2026 - 09:07 EDT