FRS currently unavailable

Incident Report for U of G IT System

Resolved

FRS is now back online. We apologize for any inconvenience.

We appreciate your patience and support during this service interruption.
Posted Sep 23, 2026 - 11:00 EDT

Investigating

FRS is currently not available and investigation in progress.
Posted Sep 23, 2026 - 10:03 EDT