Ridgetown Campus Internet Down

Incident Report for U of G IT System

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 23:56 EDT

Monitoring

The network connectivity to Ridgetown campus has been restored around 6pm. We are still closely monitoring the situation at this moment.
Posted Jul 08, 2025 - 18:47 EDT

Update

Internet services in Ridgetown remain unavailable at this time.
The issue has been identified as an infrastructure problem with Cogeco, the ISP local in the Ridgetown area.

CCS will continue to monitor the situation and provide an update here, once services have been restored.

We appreciate your patience.
Posted Jul 08, 2025 - 16:27 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 08, 2025 - 16:25 EDT

Investigating

Ridgetown campus internet is down since around 10:50am. We are investigating this issue.
Posted Jul 08, 2025 - 11:04 EDT