Some Campus Mail Delayed

Incident Report for U of G IT System

Resolved

The root cause was identified and resolved.
Posted Jul 03, 2026 - 14:08 EDT

Investigating

Some mail from the campus including Listserv messages is currently delayed. We are investigating the root cause and will update this notice before 2-Jul-2026 16:30.
Posted Jul 02, 2026 - 15:04 EDT