Service Interruption: HR Employee Portal
Incident Report for University of Guelph IT System
Resolved
HR Employee Portal is working now.

We appreciate your patience and support during this service interruption.
Posted Jan 07, 2022 - 13:43 EST
Investigating
We are experiencing an issue with the HR Employee Portal (https://hr.uoguelph.ca/EmployeePortal) where users may have issues getting pass the Challenge Questions as of approximately 12 noon. We are currently investigating the cause of this issue.

We will provide updates on this page until resolution of the issue. Next update will be at approximately 3PM.

We appreciate your patience and support as we work to resolve this issue.
Posted Jan 07, 2022 - 12:57 EST