ECS (Expense Claim System) and FRS (Financial Reporting System) Unavailable
Incident Report for CCS System
Resolved
ECS is back online.
Posted 4 months ago. Apr 10, 2018 - 10:20 EDT
Update
FRS is back online. We are continuing to investigate ECS.
Posted 4 months ago. Apr 10, 2018 - 10:08 EDT
Investigating
We are aware two financial applications ECS (Expense Claim System) and FRS (Financial Reporting System) are currently unavailable. We are working to resolve this situation as quickly as possible.
Posted 4 months ago. Apr 10, 2018 - 09:21 EDT