Guest WiFi issues

Incident Report for U of G IT System

Resolved

Services have remained stable since 2 pm. The incident is considered resolved.
Posted Feb 26, 2026 - 16:39 EST

Monitoring

Guest WiFi is fully available as of 2 pm.
CCS will continue to monitor services.

Thank you for your patience.
Posted Feb 26, 2026 - 14:41 EST

Investigating

We are experiencing issues with Guest WiFi access and are currently investigating the cause of this problem.

CCS will provide updates on this page until resolution of the issue.

We appreciate your patience and support as we work to resolve this issue.
Posted Feb 26, 2026 - 13:33 EST