Website page and menu loading Issues on U of G website

Incident Report for U of G IT System

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 09:47 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 13:54 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 20, 2025 - 13:39 EDT

Update

In addition to the menu, we are also noticing webpage loading issues with various University of Guelph websites. We believe this issue is related to the widespread AWS outage that is currently affecting multiple global services.

We will provide updates on this page until resolution of the issue. Next update will be at approximately 1:30 pm.

We appreciate your patience and support as we work to resolve this issue.
Posted Oct 20, 2025 - 12:34 EDT

Investigating

We are experiencing Menu loading issues with the University of Guelph website as of approximately 10:20 am. We are currently investigating the cause of this issue.

We will provide updates on this page until resolution of the issue. Next update will be at approximately 1:00 pm.

We appreciate your patience and support as we work to resolve this issue.
Posted Oct 20, 2025 - 11:38 EDT