On-campus University card payment system currently unavailable
Incident Report for University of Guelph IT System
Resolved
The On-campus University card payment system is now available.

Thank-you for your patience.
Posted Apr 26, 2024 - 10:06 EDT
Identified
CCS and Hospitality have identified the technical root cause for the service outage.
Efforts to fix the issue will continue into the evening.
Debit and credit transactions were uninterrupted and remain available.

Current ETA for service availability is tomorrow (April 26) morning at 8 am.

We appreciate your patience.
Posted Apr 25, 2024 - 15:38 EDT
Investigating
We are currently investigating an issue with the servers hosting the campus payment system using university ID cards.

Currently payments with ID cards are not working. Payment options with Debit and Credit are still available.

We apologize for any inconvenience and will continue to work on recovery with the highest priority.
Posted Apr 25, 2024 - 09:50 EDT