PMP outage

Incident Report for U of G IT System

Resolved

This incident has been resolved, and service is back online.
Posted Mar 25, 2026 - 14:52 EDT

Investigating

We are currently experiencing an issue with our password manager service and are investigating.
Posted Mar 25, 2026 - 13:53 EDT