Ongoing problems with Outlook Web
Incident Report for University of Guelph IT System
Resolved
Microsoft confirms that fixes are in place for both of these Outlook Web problems.

We appreciate your patience and support during this lengthy service interruption.
Posted Apr 17, 2024 - 09:14 EDT
Update
Microsoft is deploying fixes for both of these problems and monitoring the results.

The fix for the attachments problem has been completely deployed, while the fix for the 5-minute delays is still in progress. Microsoft recommends that any users still experiencing the attachments-related problem should log out and log back in to Outlook Web.
Posted Apr 15, 2024 - 08:33 EDT
Update
These issues continue, and Microsoft continues to work on fixes. Microsoft also continues to provide updates behind the scenes, but there's nothing substantial to report. We will continue to monitor.
Posted Apr 09, 2024 - 14:39 EDT
Update
There are no substantial updates on these problems heading into the weekend. Thank you for your ongoing patience!
Posted Apr 05, 2024 - 16:06 EDT
Update
These problems persist, and Microsoft has provided some updates.

** Users may be intermittently unable to download attachments or view embedded images in Outlook on the web **
Microsoft is working on a fix but does not expect it to be completely rolled out until at least Monday, April 5 at 5:00 PM EDT.

** Some users may experience delays of up to five minutes accessing Outlook on the web and its features**
Microsoft is already deploying a short term fix, and plans to provide an update today by 3:00 PM EDT.

We will continue to monitor and pass along more information as it comes in.
Posted Apr 05, 2024 - 09:12 EDT
Identified
Microsoft has acknowledged ongoing problems with Outlook on the web, including:

- Users may be intermittently unable to download attachments or view embedded images in Outlook on the web
- Some users may experience delays of up to five minutes accessing Outlook on the web and its features

We have received reports that some U of G users are indeed experiencing these problems, so we are posting this incident and will keep it up-to-date as we learn more.

For the attachments/images problem, Microsoft suggests two workarounds:

1. Downloading attachments and embedded image viewing may succeed after an affected user signs-out and then signs-in again to Outlook on the web, if appropriate.
2. Additionally, users can download attachments and view embedded images consistently through the Outlook desktop client, if available.

We will provide updates on this page until resolution of the issue. Next update will be at approximately 9:00 AM on April 5, 2024.
Posted Apr 04, 2024 - 16:24 EDT