CCS Service Interruption: Microsoft 365 delays and failures
Incident Report for University of Guelph IT System
Resolved
Microsoft confirmed that services are now fully back online. Once again, we appreciate your patience and support during this service interruption.
Posted Jun 21, 2022 - 16:56 EDT
Monitoring
Microsoft informs us they have addressed the problem. Though they believe that many users should already be experiencing relief, they are continuing to monitor service telemetry to ensure resolution is achieved for all affected users.

We will provide updates on this page until resolution of the issue. Next update will be at approximately 4:00 PM.
Posted Jun 21, 2022 - 13:13 EDT
Investigating
Microsoft has acknowledged ongoing problems with U of G's Microsoft 365 environment. You may encounter delays and experience failures when accessing some M365 services. Impacted services include but are not limited to:

- Outlook Email and Calendar (Exchange Online)
- Microsoft Teams
- SharePoint Online
- OneDrive for Business

We are monitoring Microsoft's communications about this situation and will provide updates on this page until resolution of the issue. Next update will be at approximately 1:00 PM.

We understand this service is critical to U of G's teaching, learning, and research mission and we appreciate your patience and support.
Posted Jun 21, 2022 - 10:39 EDT