Gryph Forms Production Service Interruption
Incident Report for University of Guelph IT System
Resolved
The production service has now been restored and is available, running v. 5.24.
Posted May 27, 2020 - 17:53 EDT
Update
The Production service has been rolled back to our previous version, but we require the vendor's intervention in order to reconfigure the application database. Until then the production service will be unavailable. We apologize for any inconvenience. If you have any questions, please do not hesitate to contact me directly at ihameed@uoguelph.ca
Posted May 26, 2020 - 20:27 EDT
Monitoring
While we still have not identified all the issues that have appeared with today's upgrade. We have decided to go ahead with rolling back the upgrade in our production environment back to the previous version. We will be keeping the most up to date versions in development and test and to further troubleshoot issues with the new version. If you have any questions please feel free to contact me directly at ihameed@uoguelph.ca.
Posted May 26, 2020 - 14:12 EDT
Investigating
We are currently investigating a multitude of issues that the Gryph Forms production system since the upgrade to 5.32 was implemented this morning. These issues include:

- Some processes/forms not running but returning the following error message: SDK ERROR: 'GetFormObjectByID': 'Could not find eForm control; it may have been deleted.'

- Some CSS changes that may affect the look and feel of forms.

- Custom date form controls not appearing on forms.

We are also currently trying to find out if there are any more issues being experienced and are working to resolve them as soon as possible. If you have any questions please feel free to contact me directly at ihameed@uoguelph.ca

Thank you for your patience.
Posted May 26, 2020 - 12:05 EDT