O365 Service Interruption: Unable to Download Attachments from Chrome Browser
Incident Report for University of Guelph IT System
Resolved
Microsoft has received confirmation from Google that this issue is now resolved. Google Chrome has been updated to fix this issue. Users are encouraged to update Google Chrome if they see this issue, and clear their stored cookies and browser cache. Thank you!
Posted Oct 22, 2018 - 16:15 EDT
Monitoring
A recent update to Google Chrome has created issues for some users attempting to download attachments from emails in the Outlook Web application. Microsoft is aware of the issue, however because this was caused by a Chrome update, they are waiting on information from Google as to when this will be fixed. Updates will be provided as Microsoft evaluates how to best address this issue. In the mean time, users can access their email from another browser, and downloading attachments will work as normal.
Posted Oct 19, 2018 - 11:21 EDT