Resolved: Password management service unavailable since 5 AM
Incident Report for University of Guelph IT System
Resolved
We have identified the issue and recovered both services. Thank you for your patience.
Posted 6 days ago. Apr 16, 2019 - 10:02 EDT
Investigating
The Password Change and the Password Insurance a.k.a. Password Reset services are presently unavailable. We are working on restoring these services. Next update 10 AM.
Posted 6 days ago. Apr 16, 2019 - 08:59 EDT