OneDrive for macOS 11.6 issue
Incident Report for University of Guelph IT System
Resolved
This incident has been resolved.
Posted Sep 17, 2021 - 13:54 EDT
Update
Microsoft has indicated that this issue is resolved and that the fix for this issue has propagated through our environment successfully. If you are still experiencing issues with OneDrive and macOS 11.6, Microsoft has also issued an update to the OneDrive client (available from the App Store) that resolves the issue as well.
Posted Sep 17, 2021 - 13:54 EDT
Monitoring
Microsoft has indicated there is an error affecting Mac users of the OneDrive client that sign into both OneDrive for Business and OneDrive Personal accounts,. The error as describe by Microsoft is:

This problem mostly affects users attempting to sign into both a personal account and a business account on the same device, but also impacts users signing into two business accounts. The issue only impacts users who have updated their devices to macOS 11.6. The issue also impacts both the OneDrive for Mac standalone sync client and the OneDrive on the Mac app acquired through the App Store.

Microsoft has deployed a fix for this issue, but it has not reached our tenant yet. We are monitoring Microsoft's Service Health for a resolution. The OneDrive web experience is not affected by this issue.
Posted Sep 16, 2021 - 11:41 EDT