Financial Systems Service Interruption
Incident Report for CCS System
Resolved
All finance systems and applications are back online.
Posted 3 months ago. Mar 10, 2018 - 09:47 EST
Identified
The following systems are currently offline for maintenance and will be available Saturday morning: iProcurement, WebADI, Expense Claim System (ECS), and Financial Reporting System (FRS)

We will post another update when the services are back online.
Posted 3 months ago. Mar 09, 2018 - 16:18 EST