Slow mail delivery in Office 365
Incident Report for CCS System
Resolved
Microsoft has completed resolution of this issue and mail delivery times have returned to normal. Anyone continuing to experience issues should contact the service desk at 519.824.4120x58888 or 58888help@uoguelph.ca.
Posted about 1 month ago. Mar 24, 2018 - 04:54 EDT
Identified
Microsoft has reported mail delivery issues in Office 365. It seems to be primarily affecting mail sent to or from Office 365. Internal mail is less affected.
We will monitor the situation and provide updates as they come available.
Posted about 1 month ago. Mar 23, 2018 - 15:49 EDT