Power outage at Ridgetown Campus
Incident Report for CCS System
Resolved
The power has been restored at 9:30 PM.
Posted 8 months ago. Apr 03, 2017 - 22:21 EDT
Identified
There is a power outage at the Ridgetown Campus tonight. The complete computer and phone network is down. It is expected that the power will be restored around 10PM tonight.
Posted 8 months ago. Apr 03, 2017 - 21:17 EDT