Web-Based Versions of Office Apps May Not Load
Incident Report for CCS System
Resolved
Microsoft has issued an update that has resolved this issue. All online versions of Office 365 apps should be back to functioning normally now.
Posted 23 days ago. Jan 30, 2018 - 11:11 EST
Identified
The online (web-based) versions of Microsoft Word, Excel, and PowerPoint are currently experiencing issues loading from the Office 365 menu. Users who have existing documents from these programs stored in OneDrive can still open and edit these documents as normal through the OneDrive interface, but attempting to load Word, Excel or PowerPoint directly from the 'waffle' in the top, left-hand corner of the Office 365 interface will produce an error. Microsoft is aware of the issue, and we will report back once it has been resolved.
Posted 27 days ago. Jan 26, 2018 - 09:30 EST