Update: Some UoGuelph Mail Still Blocked by Hotmail and Outlook.com
Incident Report for CCS System
Resolved
Microsoft has confirmed that this issue is resolved, and our testing has not yielded any further delays or errors in sending emails to Microsoft-owned accounts. If you see any further problems with non-O365 mail systems emailing Hotmail, Outlook, Live or other Microsoft-owned email accounts, please contact the Help Center at x58888 or 58888help@uoguelph.ca. Thank you!
Posted 2 months ago. Mar 15, 2018 - 16:23 EDT
Update
We have received a response from Microsoft detailing that both of the on-campus mail servers are no longer blacklisted from sending mail to Hotmail, MSN, Outlook, Live and other Microsoft-owned email accounts. There may still be some delays in mail sending, as it’s likely that our connection will remain temporarily throttled as part of Microsoft’s resolution process, but we are no longer seeing bouncebacks from emails sent, and no longer hearing reports of issues from on-campus groups sending mail.

If you administer processes or applications that send mail from @uoguelph.ca email addresses outside of Office 365, please continue to monitor your mail logs to confirm that there are no issues affecting your mailouts, but at the moment we can consider this issue resolved. Please direct any further questions to the Help Center at x58888 or 58888help@uoguelph.ca
Posted 2 months ago. Mar 13, 2018 - 13:24 EDT
Monitoring
It appears that the issue sending to Hotmail and Outlook accounts from non-O365 mail systems is still active, and causing bouncebacks on some email systems on campus. CCS has reached out to Microsoft now that we have identified and removed the email issue on campus that was responsible for the block, and we will report back once we have a guarantee from Microsoft that all of our servers and IPs have been unblocked. Thank you for your patience on this, and please contact the help center at x58888 or 58888help@uoguelph.ca if you have any further questions.
Posted 3 months ago. Mar 08, 2018 - 11:38 EST