Some UoGuelph Mail Blocked by Hotmail and Outlook.com
Incident Report for University of Guelph IT System
Resolved
Email delivery to Hotmail and Outlook.com addresses from non-O365 systems has been fully restored. If you experience any further issues with this, please contact the help center at x58888 or 58888help@uoguelph.ca. Thank you!
Posted Mar 08, 2018 - 09:50 EST
Monitoring
We have received word from Microsoft that they are in the process of removing us from the blacklist affecting Hotmail and Outlook.com delivery from non-O365 systems. CCS should have a more solid update tomorrow morning, Thank you for your patience on this as we work with Microsoft to resolve the issue.
Posted Mar 07, 2018 - 16:27 EST
Identified
We recently became aware of an issue blocking some University of Guelph mail being sent to Microsoft email users (Hotmail, Outlook.com, and other branded Hotmail accounts) that will prevent delivery of messages to these platforms. Emails sent through on-campus mail systems outside of Office 365 (Listserv, departmental email servers, etc.) are currently unable to send messages to Hotmail or Outlook.com accounts, however sending emails from Outlook web or desktop will be unaffected, and will be delivered successfully.

Currently we have seen systems from the registrar’s office and Listserv affected, but any non-O365 email may fall into this category. We are working with Microsoft to mitigate this as quickly as possible, but it may take 24-48 hours for this to be resolved. If you are sending mail from the University of Guelph using a process outside of Office 365, please review your mail logs to see if there have been any delivery issues to external Microsoft accounts. Please direct any questions to the Help Center at x58888 or 58888help@uoguelph.ca.
Posted Mar 07, 2018 - 11:16 EST