Gryph Mail Certificate Warning
Incident Report for CCS System
Resolved
The security certificate has been updated and the web warning no longer appears.

Anyone continuing to have concerns should contact the service desk at 519.824.4120x58888 or 58888help@uoguelph.ca.

Again, we apologize for the inconvenience.
Posted 7 months ago. Apr 06, 2017 - 09:22 EDT
Identified
The security certificate for web access to Gryph Mail has expired. This is leading to warnings when attempting to access mail through a web browser. Resolution is expected to occur shortly.

Until resolved, mail can still be accessed through client software, mobile devices, etc. It is also possible to accept the browser security warning and proceed to Gryph Mail using a browser.

We regret this inconvenience and will provide an update when the issue is fixed. Anyone with questions or concerns can contact the service desk at 519.824.4120x58888 for guidance.
Posted 7 months ago. Apr 06, 2017 - 08:48 EDT